MilesWeb
MilesWeb Hosting Forum

Please login or register.

Login with username, password and session length

 

News:

SMF - Just Installed!


Author Topic: Mysql- "Another MySQL daemon already running with the same unix socket."  (Read 4211 times)

0 Members and 1 Guest are viewing this topic.

Offline Dipak Bhoi

  • MilesWeb Team Member
  • Full Member
  • ***
  • Posts: 208
  • Karma: +5/-0
    • View Profile
    • MilesWeb Internet Services
Hello guys,

Today I faced new issue, when I was starting the mysqld service, it was throwing an error as below.

Quote
#service mysqld start
Another MySQL daemon already running with the same unix socket.
Starting mysqld:                                           [FAILED]

I tried all possible ways to kill the process of mysqld, rebooted my VPS, but it was of no help.

Further investigating, I found that the file /var/lib/mysql/mysql.sock. I have just moved this file as /var/lib/mysql/mysql.sock.backup and had tried to start the service, WOW! problem was solved.

Quote
# mv /var/lib/mysql/mysql.sock /var/lib/mysql/mysql.sock.backup

# service mysqld start
Starting mysqld:                                           [  OK  ]
« Last Edit: January 17, 2014, 01:06:34 PM by Dipak Bhoi »
MilesWeb.com
cPanel Hosting in India - cPanel Hosting in India.

Grab an SSL for your website and SAVE 20% now. Coupon Code SSLSAVE20.

MilesWeb Hosting Forum